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1.0    The Menus

These menus are associated with the Main program:
1.1        The File Menu
1.2        The Turn Menu
1.3        The Units Menu
1.4        The Assault Menu
1.5        The Reinforce Menu
1.6        The Status Menu
1.7        The Display Menu
1.8        The AI Menu
1.9        The Special Menu
1.10    The Options Menu
1.11    The Help Menu



1.1    The File Menu

The File Menu is used to start a new battle and to load and save previously created battles.
To save the current battle, select the Save menu item. By default, battle files are saved with the
.btl filename extension.
To save the current battle under a different filename, select the Save As menu item.
A recorded battle can be replayed by selecting the Replay menu item. A dialog will be 
displayed allowing the replay file to be selected. By default, replay files have the .btr filename 
extension. A Battle Replay can be paused once started by pressing the Escape key. The Restart 
Replay option of the Special Menu is used to restart the replay.
To exit the Main program, select the Exit menu selection.



1.2    The Turn Menu

Selecting the Next menu item causes the current player turn to end and the battle to advance to
the next player turn.



1.3    The Units Menu

Selecting the To Top menu item moves the selected units to the top of the stack.
Selecting the To Bottom menu item moves the selected units to the bottom of the stack.
To load units, first select both passenger and carrier units and then select the Load/Unload 
menu item. To unload units, select the carrier unit and then select the Load/Unload menu item.
The Toggle Digging-In menu item toggles the Digging-In status of the selected units.
The Double-Time menu item initiates Double-Time movement for the selected units.
The Save AP's for Firing menu item causes the number of Action Points required to fire to be 
set aside for the selected units.
The Save AP's for Unloading menu item causes the number of Action Points required to 
unload to be set aside for the selected units.
Selecting the Turn Clockwise menu item causes the selected units to turn clockwise.
Selecting the Turn Counterclockwise menu item causes the selected units to turn 
counterclockwise.
Selecting the Air Attack menu item causes an Air Attack to be initiated on the current Hot Spot
hex.
Selecting the Artillery Dialog menu item displays the Artillery Dialog so that artillery units 
can be fired.
Selecting the Assign Opportunity Fire menu item displays the Opportunity Fire Dialog, which 
allows the player to set certain range restrictions for his unit's opportunity fire.
Selecting the Remove From Map menu item causes the selected units to be removed from the 
map. Units to be removed from the map must be on the boundary of the map.
Selecting the Undo Last Movement menu item causes the last movement of units to be 
undone. Note that movement cannot be undone if Fog-Of-War is in effect for the other side.



1.4    The Assault Menu

Selecting the Cancel Assault menu item will reset an assault on the map that has not been 
resolved.
Selecting the Add To Assault menu item will cause the currently selected units to be added to 
the current assault.
Selecting the Resolve Assault menu item will resolve the current assault.
The Show Odds menu item will - unless Extreme Fog of War is in effect - display the combat 
odds associated with the current assault prior to its resolution.



1.5    The Reinforce Menu

To view the reinforcements scheduled to appear in the current battle, select the Scheduled 
menu item.
To view reinforcements that are available to be placed on the map this turn, select the Arrived 
menu item.
To view the list of Fixed-Unit Releases, select the Releases menu item.



1.6    The Status Menu

Selecting the Scenario Information menu item displays a dialog with various information 
about the current scenario such as title, maximum visibility, ground conditions, and number of 
turns.
To view the current strengths of each side, select the Strength menu item.
To view a list of objectives and their current owner, select the Objectives menu item.
To view the current victory level, select the Victory menu item.



1.7    The Display Menu

Selecting the Units Off menu item causes the units on the map to be hidden so that the 
underlying terrain can be viewed better.
Selecting the Unit Bases menu item toggles the display of bases on the 3D units.
Selecting the Specials On Top menu item toggles the display of special counters on the top of 
each stack in the 2D view.
Selecting the Objectives menu item toggles the display of objective hexes on the map with 
ownership designations.
Selecting the Locations menu item displays the Location Dialog.
Selecting the Visible Hexes menu item shades the hexes which are not visible from the current
Hot Spot hex.
Selecting the Reachable Hexes menu item shades the hexes that cannot be entered by the 
currently selected unit during the current turn.
Select Command Range when a HQ or CP units is selected to see the Command Range for that
unit. 
Selecting the Find Org menu item displays the Organization Dialog.
Selecting the Jump Map menu item displays the Jump Map.
Selecting the Hex Contours menu item toggles the drawing of hex contours which help 
visualize elevation changes on the map.
Selecting the Opaque Infobox menu item toggles the drawing of the Infobox with an opaque 
background to improve legibility.
Select On-Map Thermometers to toggle (off or on) small “thermometers” on a 3D map display
that graphically illustrate each unit’s current state of morale, remaining Action Points or 
current Strength Points.
Select Range to display the range of the hard (shown in red) and soft (blue) attack limits of the
selected unit.
The Highlight submenu contains several selections for identifying certain units on the map.
Selecting the Spotted Units menu item highlights units that are currently spotted on the map.
Selecting the Fired/Fought Units menu item highlights units that have either fired or 
conducted assaults in the current turn.
Selecting the Moved Units menu item highlights units that have moved in the current turn.
Selecting the Disrupted Units menu item highlights units that are currently disrupted.
Selecting the Indirect Fire Units menu item highlights units capable of firing using Indirect 
Fire.
Selecting the Anti-Aircraft Units menu item highlights units capable of firing using Anti-
Aircraft Fire.
Selecting the Organization menu item highlights all units belonging to the same organization 
as the currently selected unit.
Selecting the Mine Clearing Units menu item highlights all units that can clear mines.
Selecting the Leaders menu item highlights all leaders on the map.
Selecting the Headquarters menu item highlights all headquarters units on the map. If the 



Optional Rule for Command Control is enabled, “Command Post” units are also highlighted.
Selecting the Fixed Units menu item highlights all fixed units on the map.
Selecting the 2D Normal View, 2D Zoom-Out View, 3D Normal View, 3D Zoom-Out View, 
or 3D Extreme Zoom-Out View displays the corresponding map view.
Selecting the Rotate Map menu item rotates the map 180 degrees.



1.8    The AI Menu

Each side can be set to Manual, Computer, or Computer with Fog-of-War AI. Under Manual 
AI, all actions are taken by the user. Under Computer and Computer with Fog-of-War, the 
computer moves and fires all units for the selected side. Under the Fog-of-War option, the 
opposing side can only see enemy units that are visible from one or more of their units. 
Selecting the Manual, Computer, and Computer with FOW menu items sets the AI for the 
corresponding side.
The Activate AI menu item starts and stops the execution of the AI for the current side.
The Set Advantage menu item displays the Advantage Dialog.



1.9    The Special Menu

The Special Menu is used to select options for network play.
The Modem Host, Modem Caller, Play By E-Mail and Two-Player Hot Seat options of this 
menu are not usable.
The Record Battle option can be used to record a battle played either manually or against the 
computer. A file recording the battle is saved in a file with filename extension .btr. Selecting 
the Record Battle option a second time terminates the recording. Battle replay files can be 
replayed using the Replay option of the File Menu.
The Restart Replay menu item can be used to restart a Battle Replay that was paused by 
pressing the Escape key.
The Communication Dialog menu item can be used to redisplay the Communication Dialog 
after it has been closed. The Communication Dialog is available only during Modem play.
The Set Network Play Timer menu item can be used during a live internet game. The Host 
(only) can input a time, in minutes, that will be used by the program to automatically end each 
turn. This can be reset at any time, but only by the Host.
The Multi-Player Dialog is only useful in games with more than two players. The dialog is 
divided into a top half (listing all Allied players) and bottom half (listing all Axis players). 
Note that the “Captain” of each side is always listed in bold at the top of the player list for that
side. The “host” is always the Captain of his side. 

Along the bottom of this dialog are four buttons. Each of these buttons is used by 
selecting (clicking on) a player’s name and then clicking the button. The functions of these 
buttons, and who can use them, follows:

The Assign button is used to assign an organization to the selected player. Only the 
Captain of a side may use the Assign button.

The Deassign button is used to take the command of an organization away from the 
selected player. Only the captain of a side may use the Deassign button.

The Promote button is used to assign a new “captain” to a side. Only the “host” may use
the Promote button.

The Switch button is used to change the nationality (side) of a player. Only the “host” 
may use the Promote button.

Scroll to View Enemy Action is “off” by default in order to speed up game play. With this 
enabled, during a multi-player game the computer will scroll the map to display visible enemy 
actions.



1.10    The Options Menu

Settings under the Options Menu are saved in the Windows Registry and restored the next 
time the Main program is executed.
The Prompt for Scenario option causes the Main program to prompt the user for a new 
scenario when the Main program is executed directly without going through the West Front 
front-end application.
The Beep on Error option causes the Main program to beep when an error is made by the user.
The Hide 3D Hot-Spot option causes the 3D hot spot outline to be hidden.
The Blink Hot-Spot option causes the 2D hot spot outline to blink. Note: the 3D hot spot 
outline does not blink even when it is visible.
The Smooth Scroll option causes the map to scroll through all intermediate hexes when it is 
repositioned. Otherwise, the map is immediately redrawn at the new location.
The Hex Outlines option causes hex outlines to be drawn on the map.
The Sound Effects option causes combat sound effects to be played during battle.
The Background Music option causes background music to be played during a battle.
The Background Sound option causes background combat sound effects to be played during a 
battle. Note that this option and Background Music cannot both be enabled simultaneously.
The Graphical Icons option causes graphical icons to be displayed on counters in 2D modes. 
Otherwise, schematic NATO-style icons are drawn.
The Unit List option causes a list of units in the current Hot Spot hex to be displayed along the
right-hand side of the screen. Otherwise, units are displayed using the Infobox.
The Auto Save option causes the current battle file to be automatically saved at the end of 
every turn not under AI control.
The Auto Save AP's for Firing option causes the Action Points required to fire to be set aside 
for each unit at the beginning of each player turn.
The Details submenu controls the level of detail associated with reports and information 
generated the game. Higher levels of detail increase the amount of information reported to the 
user.
The Fast Computer Player option will cause 3D animations to play at a faster speed when the 
computer is resolving movement and fire by the computer-controlled opponent.
The Ask Before Advancing Turn option prompts you to confirm your intention to end the turn.
The Use Special Icons option will enable the program to use special 3D icons, such as winter 
or desert camouflage, or early/late-war colors.
The Initial View submenu controls the initial map view when the Main program is first 
executed, as follows:

The Last View option causes the map to be redisplayed using the same view as when the
Main program was last exited.
The 2D Normal View, 2D Zoom-Out View, 3D Normal View, 3D Zoom-Out View, and 
3D Extreme Zoom-Out View options select the initial view for the Main program 
correspondingly.

The Optional Rules… menu item displays the Optional Rules that are in effect for the current 



scenario. These rules must be set at the start of a scenario and cannot be changed during game 
play. 



1.11    The Help Menu

The General Help menu item displays this help file.
The Unit Handbook menu item displays the Unit Handbook help file.
The Parameter Data menu item displays the Parameter Data help file.
The Unit Data menu item displays miscellaneous data about the units in the game, such as 
Strength Points, platoon VP value, Assault value, Defense Strength, etc.
The Weapon Data menu item displays a list of the units’ effective ranges vs. hard and soft 
targets, and their attack strengths at those ranges. The upper line shows the range and attack 
strength vs. hard targets, and the lower line shows the range and attack strength vs. soft 
targets.
The About menu item displays information concerning the West Front version and copyright.



2.0    The Dialogs

These dialogs are associated with the Main program:
2.1        The Target Dialog
2.2        The Artillery Dialog
2.3        The Strength Dialog
2.4        The Victory Dialog
2.5        The Objectives Dialog
2.6        The Advantage Dialog
2.7        The A/I Selection Dialog
2.8        The New Scenario Dialog
2.9        The Arrived Dialog
2.10    The Schedule Dialog
2.11    The Release Dialog
2.12    The Jump Dialog
2.13    The Organization Dialog
2.14    The Location Dialog
2.15    The Rule Dialog
2.16    The Opportunity Fire Dialog



2.1    The Target Dialog

The Target Dialog appears whenever a direct-fire attack is made into a hex that contains more 
than one potential target. Selecting a target unit and clicking OK, or double-clicking on a 
target unit, causes the fire to be directed at that unit.



2.2    The Artillery Dialog

The Artillery Dialog is used to conduct Indirect Fire attacks during a player's turn. Selecting a 
unit in the dialog and right-clicking on the map causes the unit to fire at the selected map hex. 
Units that are in range of the selected artillery unit are highlighted on the map. Clicking on the
Locate button, or double-clicking on an artillery unit's name in the dialog, causes the map to 
scroll to that unit on the map.



2.3    The Strength Dialog

The Strength Dialog lists the units which are on the map for each side. Associated with each 
unit type is the number of units of that type and the Victory Points associated with that unit.



2.4    The Victory Dialog

The Victory Dialog displays the current victory level. Victory Points are calculated based on 
the objectives held by the first side in the scenario. Depending on the total victory points, the 
first side is awarded a Major Defeat, Minor Defeat, Draw, Minor Victory or Major Victory.



2.5    The Objectives Dialog

The Objectives Dialog lists the objectives in the current battle, their ownership, and their 
victory-point value. Clicking on an objective in the dialog causes the map to scroll to that 
objective hex.



2.6    The Advantage Dialog

The Advantage Dialog can be used to display, and perhaps modify, the current Advantage 
Value of the current battle. Note: the Advantage Value of Play-By-E-Mail and Modem Play 
battles cannot be changed after the battle has started.



2.7    The A/I Selection Dialog

The A/I Selection Dialog is used to select the A/I setting of each side in a new battle and to 
select any Advantage Value. The A/I setting of a side can be Manual, in which case the player 
moves and fires the units for that side; or Computer, in which case the computer moves and 
fires the units for that side. In addition, for a side controlled by the computer, the Fog-Of-War 
option can be set which prevents the player from seeing enemy units on the map that are not 
visible to friendly units.
 Setting the Advantage Value to a value other than 0 gives that side an advantage in combat 
and the other side a corresponding disadvantage.



2.8    The New Scenario Dialog

The New Scenario Dialog is used to make selections under special play modes such as Modem
Play or Play-By-E-Mail. The local user can select which side they wish to play and if Fog-of-
War should be in effect during the battle. Note that the Advantage value can be set in this 
dialog, but cannot be changed during the course of battle.



2.9    The Arrived Dialog

The Arrived Dialog is used to display units which have arrived as reinforcements and to place 
those units on the map. Selecting an entry in the Arrived Dialog causes the map to scroll to the
arrival location. Double clicking on the entry causes the units to be placed on the map.



2.10    The Schedule Dialog

The Schedule Dialog displays a list of reinforcements for the current scenario. Associated with
each reinforcement entry is an arrival location, an arrival turn, and a probability of arrival at 
that time. If the probability is less than 100%, then the reinforcement may not arrive at the 
exact arrival turn, but may arrive at a later time. An asterisk (*) preceding the reinforcement 
entry indicates that the reinforcement is late in arriving. Selecting a reinforcement entry causes
the map to scroll to the entry hex. Double-clocking a reinforcement entry displays a list of the 
units in that reinforcement.



2.11    The Release Dialog

The Release Dialog displays a list of Fixed-Unit releases for the current scenario. Associated 
with each release is a turn and a probability that the release will be applied at that time. If the 
probability is less than 100%, then the release may not be applied at the exact time noted, but 
may be applied at a later time.



2.12    The Jump Dialog

The Jump Dialog displays a reduced version of the current map. Units that are visible on the 
map are indicated, and the current visible portion of the map is indicated by a red rectangle. 
Clicking on any portion of the map causes the map to be repositioned to that location.



2.13    The Organization Dialog

The Organization Dialog displays the organizations associated with the current battle. 
Selecting an entry in the list highlights that organization's units on the map. Clicking OK 
closes the dialog but leaves highlighted units still highlighted. Clicking Cancel closes the 
dialog and removes the highlighting.



2.14    The Location Dialog

The Location Dialog displays a list of map locations. Clicking on an entry in this list causes 
the map to scroll to that location.



2.15    The Rule Dialog

The Rule Dialog displays the settings for the Optional Rules currently in effect for a battle. 
Note that Optional Rules can only be changed at the beginning of a battle and not after it has 
started.



2.16    The Opportunity Fire Dialog

The Opportunity Fire Dialog allows the player to exert a degree of control over his units' 
opportunity fire by letting him select (at any time during his turn) maximum engagement 
ranges for certain firing unit types vs. certain target types. In the Opportunity Fire dialog, 
target types are listed across the top and firing types are listed along the side. For each 
combination of firing unit vs. target unit, one of four settings is possible. The setting N 
(Never) forces units of the given firing type to never fire at units of the corresponding target 
type. The setting S (Short) restricts opportunity fire between the given firing type and 
corresponding target type to 1/3 of the firing unit's maximum range. M (Medium) restricts 
opportunity fire to 2/3 of the firing unit's maximum range. L (Long) allows opportunity fire 
out to the firing unit's maximum range. 



3.0    Other Features
These features are associated with the Main program:

3.1    Hot Keys
3.2    Min-Path Algorithm
3.3    Optional Rules



3.1    Hot Keys

These hot keys can be used in the Main program:
F1 - Open Main program help file
F2 - Open Unit Handbook
F3 - Open Scenario Parameter Data help file
F4 - Open Miscellaneous (Platoon) Data file
F5 - Open Weapon Data file
Keyboard 1 - Display in 3D Normal mode
Keyboard 2 - Display in 3D Zoom-Out mode
Keyboard 3 - Display in 3D Extreme Zoom-Out mode
Keyboard 4 - Display in 2D Normal mode
Keyboard 5 - Display in 2D Zoom-Out mode
Number Pad 0 - Load/unload units
Number Pad 1 - Move selected units down and left
Number Pad 2 - Move selected units down
Number Pad 3 - Move selected units down and right
Number Pad 4 - Turn selected units counter-clockwise
Number Pad 5 - Initiate air attack on current Hot Spot hex
Number Pad 6 - Turn selected units clockwise
Number Pad 7 - Move selected units up and left
Number Pad 8 - Move selected units up
Number Pad 9 - Move selected units up and right
Ctrl - Toggle between Move Mode and Fire Mode
Alt - Used to fire Smoke; also for Organizational Movement
Shift - Displays map labels; also for Organization Movement
Delete - Turn selected units counter-clockwise
Page Down - Turn selected units clockwise
Home - Move selected units forward in hex
End - Move selected units backward in hex
A - Display Arrived Dialog
C - Toggle display of map contours
D - Display Opportunity Fire Dialog
F - Display Release Dialog
H - Display hexes reachable by currently selected unit
I - Display scenario information
M - Toggle display of program menu
N - Advance to next unit to move or fire
O - Toggle display of objectives
P - Return to previous unit to move or fire



R - Rotate map 180 degrees
S - Display Schedule Dialog
T - Toggle display of on-map thermometers
U - Toggle display of Unit List
V - Display hexes visible from selected hex/unit
W - Toggle display of HQ comand range
X - Exit Main program
Z - Displays range of selected unit
Up Arrow - Scroll map up
Down Arrow - Scroll map down
Right Arrow - Scroll map right
Left Arrow - Scroll map left
Space Bar - Re-center map on selected hex/unit



3.2    Min-Path Algorithm

There are three implementations of the Min-Path Algorithm in the game. Each has 
characteristics in terms of speed and accuracy.
When a unit is moved by the player, the default Fast Min-Path Algorithm is used. This 
implementation attempts to find a Min-Path to the destination hex subject to the restriction that
the distance from the intermediate hexes of the path to the destination hex must not exceed the
distance from the unit to the destination hex. The goal of this restriction is to avoid wild 
detours to the destination hex that may be unexpected and totally unwanted by the player. For 
example, in a river crossing situation, if the main bridge is currently unable to accommodate 
more units, then a pure Min-Path could end up moving the unit a great distance away from the 
main bridge so as to reach a secondary bridge over the river. If the Fast Min-Path Algorithm is 
unable to find a path, then the player is told that there is no "Direct Path" to the destination 
hex.
A generalization of the default Min-Path Algorithm that looks for small detours to the 
destination hex is also available to the player. This algorithm, the Slow Min-Path Algorithm, 
takes longer than the default algorithm but will consider small detours in order to find paths 
around obstructions such as rivers. This algorithm is invoked by holding down the Alt key 
when the unit is moved.
The Slow Min-Path Algorithm is also the basis for Organization Moves. To perform an 
Organization Move, first highlight the organization to be moved and then select the destination
hex for the organization by holding down the Alt key and clicking with the right mouse 
button. The Organization Move will move each unit of the organization in turn towards the 
destination hex.
Finally, a pure implementation of the Min-Path Algorithm is used when the Reachable Hexes 
of a unit are displayed (see the Display Menu). This algorithm takes much longer than the 
other two but will find the absolute Min-Path to all hexes within the movement allowance of 
the unit. If a unit is moved while the Reachable Hexes are displayed, then the Min-Path found 
by this algorithm is used to move the unit.



3.3    Optional Rules

These Optional Rules can be established at the beginning of a battle. However, once set, they 
cannot be changed during the battle.
Indirect Fire By The Map - Under this rule, Indirect Fire can be targeted at hexes that are not 
currently spotted by friendly units. However, such fire has reduced effectiveness and is subject
to drift.
Extreme Fog-Of-War - This rule affects Fog-Of-War effects. When in effect, additional 
information is hidden from the opposing player such as the name of enemy units, their morale,
and their strength (except in Open hexes). In addition, when the opposing side has Extreme 
Fog-Of-War, then the arrival probability and release probability of friendly units are not 
reported.
Armor Facing Effects - Under this rule, Direct Fire against hard (armored) targets is affected 
by the facing of the target unit. Fire that is directed through the three 'frontal' hexsides of the 
target unit is considered to be directed against its Front facing. Fire directed through the two 
'rear flank' hexsides of the target unit is considered to be directed against its Side facing. 
Finally, fire directed through the 'rear' hexside of the target unit is considered to be directed 
against its Rear facing. The defense strengths used for these facings are listed in the 
MiscellaneousUnit/Platoon Data; press the F4 key or select Unit Data from the Help menu in 
the game (see the "F", "S" and "R" columns under "Opt. Armor").
Command Control - Under this rule, the HQ supply "ranges" are varied depending on the year 
and the nationality. Each nationality has a built in modifier that modifies the base "50% range"
of each HQ. For example: In 1942, each German HQ has a 120 % (1.20) modifier that is 
applied to modify the base range of each HQ (as seen in West Front's Pdata.hlp file). Thus, a 
battalion HQ that normally has a 50% range of "8" has that multiplied by 1.20, resulting in a 
new "50% range" value of "10". 
In addition to the above modifier (depending on year and nationality), any HQ that is stacked 
in the same hex with the leader associated with that HQ has its base "50% range" increased by 
that leader's Leadership#. For instance, a divisional-level leader only increases the range of his
division's HQ, not the regimental and/or battalion HQ of his division.
Command Post: If the Optional Rule for "Command Control" is enabled, a company-level 
"Command Post" (CP) is deemed to be inherently present with the first platoon of each 
company. If the first platoon is eliminated, the benefits of the CP are lost (it would be 
unrealistic to have the CP duties passed on in the time frame of a typical scenario). A CP unit 
is denoted by a radio icon displayed in the icon area along the left side of the Info Box. In 
addition, all friendly CP units are highlighted when you select Highlight HQ.

Units that operate beyond their company CP range (or if their CP is not present on the 
map) are subject to the following penalties:

a) Less chance of Morale recovery (-1)
b) Less chance of Disruption recovery (-1)

A CP has an effective range (radius) which is about half the range of that side's battalion HQ. 
A CP's range is highlighted if it's selected when the W hot key is pressed.






